Career Connections

Text Alert

Get Connected

D2L Technical Requirements


System Requirements (LE 10.3, effective May 10, 2014) ~ Run a System Check

Please note that the information below is from the Desire2Learn. Alternative and newer versions of the listed operating systems and browsers may or may not work properly with D2L. We will submit any reported problems to Desire2Learn for newer operating systems and browsers. To report a problem, please email ltcsupport@clarion.edu.


Required

Recommended

Operating System

Windows Vista, Windows 7, Windows 8

Mac OS X 

Windows 7

Video

Minimum resolution of  800 x 600, SVGA Monitor

Resolution of 1024 x 768 or greater

Internet Speed

56K Modem

56K or cable modem, DSL, broadband



Software Requirements


Required

Recommended

Java Runtime Enviroment (JRE)

JRE 1.6.x
(Required to run Equation Editor)

JRE 1.6 or newer

JavaScript

Enabled

Enabled

Cookies

Enabled

Enabled


Browser Support

If desired, Windows 7 users can  rollback to IE 10 using the Windows Uninstall Update tool.  The steps to uninstall IE 11 are as follows:

  1. Start > Control Panel > Programs > Uninstall Program (category view) OR Programs and Features (icon view)
  2. Select "view installed updates" from the left side panel
  3. Scroll down and select "Microsoft Internet Explorer 11" from the list of installed updates
  4. Click on "Uninstall" from the toolbar in the column header.

** Clarion University is running D2L version 10.3, SP 6 (updated 6-16-2014)

Browser

Windows

Mac OS X

Mobile Web

Tablet Support for Desktop Web

Firefox (newest)

Supported (recommended)

Supported (recommended)

 

 

Firefox 24

Long Term Support

Long Term Support

   

Firefox (older)

Unsupported

Unsupported

   

Internet Explorer 11

Supported for 10.3 SP4 or higher**

-


   

Internet Explorer 10

Supported (recommended)

-
 


Internet Explorer 9

Supported

-

   

Internet Explorer 8

Unsupported

-

   

Chrome (newest)*

Supported (recommended)

Supported

   

Safari 7.0


Investigation

   

Safari 6.0

-

Supported

   

Safari 5.1

-

Supported

   

Safari (older)

-

Unsupported

   

iOS 3 (iPhone, iPod Touch 1)

- -

Unsupported

 

iOS 4 (iPhone 3G, iPod Touch 2)

-
-

Unsupported

 

iOS 5 (Safari 5.1)

   

Maintenance

 

iOS 6 (iPhone 3GS/4/4S/5, iPod Touch 4/5, iPad 2/3/4/mini)

   

Supported

 

iOS 6 (iPhone 3GS/4/4S/5/5C/5S, iPod Touch 4/5, iPad 2/3/4/mini)

   

Supported

 

iOS (newest)

   

Supported

 

Android 1.5 (Cupcake)

-
-

Unsupported

 

Android 1.6 (Donut)

   

Unsupported

 

Android 2.1 (Éclair)

-
-

Unsupported

 

Android 2.2 (Froyo)

-
-

Maintenance

 

Android 2.3 (Gingerbread)

   

Maintenance

 

Android 3.2 (Honeycomb)

   

Maintenance

 

Android 4.0 (Ice cream sandwich)

   

Supported

 

Android 4.1 (Jelly Bean)

   

Supported

 

Android 4.2 (Jelly Bean)

   

Supported

 

Android 4.3 (Jelly Bean)

   

Supported

 

Android (newest)

   

Supported


Blackberry 6

-
-

Maintenance

 

Blackberry 7

   

Supported

 

Blackberry 10

   

Supported

 

Android Browser (newest) 

     

Supported

iOS Safari (newest)

 

 

 

Supported

Microsoft Surface Internet Explorer 11


   

Investigation

Microsoft Surface Internet Explorer 10

     

Supported

Playbook Browser

 

 

 

Maintenance

Disclaimer: The content provided by this site is for Clarion University students, faculty, staff use only. We do our best to keep the content in this site accurate and current.
Please email ltcsupport@clarion.edu if you find any inaccurate or outdated content.

* Some versions of Firefox (24 and higher) block some java plugins automatically (or a Firefox extension may disable java script); you may need to manually activate a java plugin or enable java script. Help with Java.  Help with Java Script

Browser Support Lifecycle

Investigation

The browser is recognized and under consideration by Desire2Learn, but has not been tested against any versions of Desire2Learn products and may never be fully supported.

This category is mainly used for new browsers that have a significant user base, good vendor support, and are generally considered as candidates for future Desire2Learn support.

Supported

The browser and operating system combination has been fully tested by Desire2Learn.

Recommended browsers are marked with an asterisk (*).

Maintenance

The browser is not tested against new versions of Desire2Learn products, but customers can still report problems and receive support for previous versions.

A browser goes into maintenance either when a vendor officially ends support for it or Desire2Learn decides to end support for it.

A maintenance browser becomes officially unsupported after one year.

Unsupported

The browser is not tested and no fixes are performed for unsupported browsers. Desire2Learn does not guarantee any product functionality and offers no support for reported problems.

Generally, Desire2Learn ends support for a browser one year after the associated vendor ends their official support for it.

ltc_d2l_home